[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

The game automatically closes down

LotharingiaLotharingia
Mabinogi Rep: 330
Posts: 4
Member
in Technical Support
The game closes down without warning sometimes. No "this game has crashed" screen or anything. How do I fix it?
Hardmuscle

Comments

  • JazmynJazmyn
    Mabinogi Rep: 5,430
    Posts: 684
    Member
    I'm not sure if you can. I have that same issue and have had it forever. I'll be doing something one minute, and the next, poof, it's just gone.
    Hardmuscle
  • HardmuscleHardmuscle
    Mabinogi Rep: 12,060
    Posts: 2,340
    Member
    edited September 7
    Jazmyn wrote: »
    I'll be doing something one minute, and the next, poof, it's just gone.

    Sunspots > Nibiru > :smirk:
     
    The game closes down without warning sometimes. No "this game has crashed" screen or anything. How do I fix it?

    Are you running the game as Administrator? This is a must.

    Are you running User Account Control? Turn it off.

    If you're running an anti-virus service while playing (real-time-scan), consider either allowing the client to run without the handcuffs (allow in exceptions) or disabling it when playing the game. If a critical process is blocked from running; such as a scan against your memory by Nexon Game Security, you'll get booted from the server without notice.

    Jazmyn
  • JazmynJazmyn
    Mabinogi Rep: 5,430
    Posts: 684
    Member
    Hardmuscle wrote: »
    Are you running User Account Control? Turn it off.

    Are there any likely negative consequences to changing it to Never Notify?
    Hardmuscle
  • HardmuscleHardmuscle
    Mabinogi Rep: 12,060
    Posts: 2,340
    Member
    edited September 7
    @Jazmyn ~ "Never Notify" is UAC's idea of "Off" ... I say that because it's not really off, but .. that's the setting it needs to be on to prevent it from blocking NGS from running when it wants to. (if NGS is prompted for permission to do its own job; it boots the client).

    If yours is off, // it could be a Connection Hiccup on either end. // there are other possibilities (list a mile long).. :)
  • JazmynJazmyn
    Mabinogi Rep: 5,430
    Posts: 684
    Member
    @Hardmuscle I understand that, or thought I did anyways. I'm just curious if it means I'll break my computer in some situation because I've turned it off. xD
    Hardmuscle
  • HardmuscleHardmuscle
    Mabinogi Rep: 12,060
    Posts: 2,340
    Member
    edited September 7
    @Jazmyn ~ Your computer won't break with it off. You just won't be prompted, an extra time, for permission when running an executable. If you don't have a habit of downloading and installing things that can download and install things on their own/ aside from windows update (behind your back), you'll be okay. :)
    Jazmyn
  • JazmynJazmyn
    Mabinogi Rep: 5,430
    Posts: 684
    Member
    @Hardmuscle - Thanks!
    Hardmuscle
  • LotharingiaLotharingia
    Mabinogi Rep: 330
    Posts: 4
    Member
    Hardmuscle wrote: »

    Are you running the game as Administrator? This is a must.

    Are you running User Account Control? Turn it off.

    If you're running an anti-virus service while playing (real-time-scan), consider either allowing the client to run without the handcuffs (allow in exceptions) or disabling it when playing the game. If a critical process is blocked from running; such as a scan against your memory by Nexon Game Security, you'll get booted from the server without notice.

    How do I check if I'm running the game as administrator/running user account control?
    Hardmuscle
  • JazmynJazmyn
    Mabinogi Rep: 5,430
    Posts: 684
    Member
    How do I check if I'm running the game as administrator/running user account control?

    I'm not sure offhand how to check if you're running the game as administrator specifically. To change user account control setting go to control panel> system and security> Change User account control settings. But, I don't believe you CAN change it if you are not already running as administrator.... @Hardmuscle might be able to elaborate more if someone else is unable to help before hand.

    That all being said, @Hardmuscle - I changed the settings and while sitting in Festia for like, 3 minutes, all of a sudden *POOF!* the game vanished anyways. Not running any other programs, as it's on my laptop.. Maybe it's a memory thing... hmm..
    Hardmuscle
  • asnscorpioasnscorpio
    Mabinogi Rep: 1,715
    Posts: 276
    Member
    edited September 11
    Usually if you right click the icon it brings up a menu to "Run as Administrator" even if you are the Administrator User...you still have to go about doing so.

    My spouse has the same computer I do and I don't have any problems with running Mabi, but my spouse DC's constantly and there is nothing on the computer. Did all the updates and scans....literally a brand new computer...factory set..took out all the various un-needed software and such and it still crashes and dc's ....and atop of it....has to re-install the launcher multiple times each time it dc's or crashes. So definately not the only one with problems...Wish Nexon NA would do a full on scan with their launcher and client to make sure it's self sustainable.


    It definitely sounds like a clash of software issues somewhere....I know I install a lot of games..mainly ones that run different net frames or direct X files. I'm wondering if it might have to do with any of those files.
    JazmynHardmuscle
  • JazmynJazmyn
    Mabinogi Rep: 5,430
    Posts: 684
    Member
    asnscorpio wrote: »
    Usually if you right click the icon it brings up a menu to "Run as Administrator" even if you are the Administrator User...you still have to go about doing so.

    When I click on play through the launcher, it brought up the "Are you sure you want to run this window" until I turned off User Account Control. It doesn't do it often enough for me to be like, "OMG IM NEVER PLAYING AGAIN", but it's still annoying... D; xD I can't run it through the Mabi icon on my laptop, it doesn't load. I had to find the launcher via the folder to actually run the app that way.
    Hardmuscle
  • asnscorpioasnscorpio
    Mabinogi Rep: 1,715
    Posts: 276
    Member
    Usually the launcher creates it own, either way the directory file location should be the same.
    I doubt this will help, but..... to set the program to run as administrator...always....it's actually under the Properties tab.

    https://technet.microsoft.com/en-us/library/ff431742.aspx
    Hardmuscle
  • JazmynJazmyn
    Mabinogi Rep: 5,430
    Posts: 684
    Member
    Ah yes, I do recall finding that for specific programs. I wasn't paying close enough attention to the wording; I thought they were referring to changing a setting so EVERYTHING runs as administrator, not specific programs.
    Hardmuscle
  • HardmuscleHardmuscle
    Mabinogi Rep: 12,060
    Posts: 2,340
    Member
    edited September 14
    Hardmuscle is growing old and sane (I've always been senile, I think)... -- :trollface: :smirk:

    Running as Administrator is the same for practically everything. Here's one way....

    Make a shortcut of the executable,
    right click on the shortcut,
    click Properties,
    in the Shortcut Tab, of the shortcut, click Advanced,
    check the box for 'Run as Administrator',
    click Ok,
    click Apply,
    click Ok,
    done.

    ~ That shortcut will always Run as Administrator.

    Here's an example using a shortcut for SQL Server Management Studio: https://imgur.com/a/R9Wn2rm.

    ~ So, what executable do we use?

    If you're playing through Steam; use a shortcut for Steam to do this.
    If you're playing through Nexon, use a shortcut for the Nexon Launcher.

    ~ You can make this change on the executable themselves (@ Properties > Compatibility Tab),
    but I think shortcuts are easier to manage (at least for me they are).

    @asnscorpio ~ You may be right about DirectX ~ Although I'm not sure why; I found the "June 2010 SDK full install / 571mb" (in Windows 10, despite support) to be a "cure-all" for Mabinogi / DirectX problems. ~ : https://www.microsoft.com/en-us/download/details.aspx?id=6812

    Jazmyn
  • JazmynJazmyn
    Mabinogi Rep: 5,430
    Posts: 684
    Member
    But there's not a box you can just check and say "Bypass this and Run Everything as Administrator"?
    Hardmuscle