Check out the P.E.T. Part 2 preview site: http://mabinogi.nexon.net/micro-site/pet/part2
Check out the patch notes for the July 16th update, P.E.T. Part 1: http://forums.mabinogi.nexon.net/discussion/23332/
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Gen 23 Across the Sands / Scattered by the Winds

DNAnimalDNAnimal
Mabinogi Rep: 600
Posts: 2
Member
in Help
I've completed the topaz dungeon twice now and nothing's happened.

I assumed this would be a rehash of the quest in Vales where you just had to complete the par ice ruins with the snowflake they give you and then the quest completes. So I didn't pay too much attention to the text.

So Hagel gives me a topaz arrow, I run the dungeon and complete it, and nothing happens. Tried talking to the NPC crew again for hints but they just keep talking about finding Longa dungeon.

Was there something else I have to do other than run topaz and talk to Marlied and co. again? Tried logging off and back on to redo it just in case it was glitched or something.

Comments

  • RikuTenshiRikuTenshi
    Mabinogi Rep: 300
    Post: 1
    Member
    It's RNG. Keep running it and you'll eventually get it. I got it on my 4th run.
  • DNAnimalDNAnimal
    Mabinogi Rep: 600
    Posts: 2
    Member
    RNG but they give you one arrow...
    Actually that sounds exactly like something this game would do

    Thank you though I was worried I got caught in some kind of glitch