Check out the patch notes for the July 16th update, P.E.T. Part 1: http://forums.mabinogi.nexon.net/discussion/23332/
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Crashes on start due to 'not enough memory'

ChaikatChaikat
Mabinogi Rep: 1,110
Posts: 43
Member
in Technical Support
When i press start, i enter the loading screen and either crash once the bar hits 100%, or right after my character and the world loads. i have 4gb ram. and can have only mabi open and it happens?? i tried restarting my computer, uninstalling and reinstalling mabi, and repairing the installation and nothing is working... i used to have a similar error on my old computer but oddly clicking on a pet on the character selecct screen and waiting for a min or two fixed it... this time its the "not enough memory" error so idk what to do >.< waiting on the character select screen doesnt do any help..

Comments

  • MiricielMiriciel
    Mabinogi Rep: 815
    Posts: 38
    Member
    64bits Windows, true?

    Well, Check off the perf. Option and the fast enter in world.

    Monitor resolution? I have problems with Mabi when i want play in 40 inch Tv.

    Other tips:

    - Dont play Mabi in Win vista
    - Play in full screen
    - Dont play with Google chrome or Firefox in background.

    Sorry for my bad english :P
  • ChaikatChaikat
    Mabinogi Rep: 1,110
    Posts: 43
    Member
    nope, im on 32bit >.< im aware that there are a lot of memory errors with mabinogi on a 32bit system but i was able to run it before with occasional memory errors, but never anything like this. it suddenly got bad about yesterday? im on a 64 bit processor but i cant really do anything about getting 64 since no muns x.x i used to only crash after a few hours of playing when entering a different region... im on windows 10, and never have any browser open in the backgrund since i use my phone for that stuff. i have my settings down to the lowest for best performance, and my screen resolution is 1366 x 768.
    just now tested getting on in fullscreen mode, and the screen started to flicker before crashing... so unfortunately that isnt working either v.v
  • SamuelalexSamuelalex
    Mabinogi Rep: 2,350
    Posts: 430
    Member
    It seems to be a problem with nexon launcher working correctly with older operating systems/computers. In my case I have 4 gb ram and win7 32-bit and have been experiencing problems since the start of g18. Recently I was able to find a partial fix by doing the following things:

    1) Do not use Nexon Launcher. Install through stream if possible. Steam will allow you to run a repair and once that is done you will want to verify the local cache files for maninogi. For me i had to right click the game in steam then properties then click local files. Then click verify integrity of game files. This will check if you have all the current files needed for game to run and try to repair any files that might be missing. Doing this helped me get back i to the game after about 2 months of crashing at the startup on my computer but I still seem to crash a lot more through steam for some odd reason.

    2) Recommended to install a program called cleanmem. It will periodically flush your temporary ram to allow more room for the currently running programs to prevent the computer from sending too much data to virtual memory. I have mine set to 2 minutes to make sure it never hits above 3gb used and it seemed to help quite a bit since between the four or five processes running by nexon my computer would hit the critical memory usage quite often (at least 2.5 gb used by nexon programs alone). I feel this is highly unusual that nexon requires so much memory to use but running cleanmem helped to clear up memory for what is actually running.

    Between those two I was finally able to get back into the game but still experience frequent and unusual crashing so other things you can try is minimizing all settings. Uncheck all visual enhancements, turn zoom down to minimum, turn fast world entry to minimum, select minimize other characters, turn on mini effects (check it) but be aware this will disable some effects in the game like making bandits invisible during commerce ect, skip transformation cut scenes, but the ones that helped me alot where disabling the title icon and disabling quest markers.

    Hope that helps you get back in,
    Sam
  • ChaikatChaikat
    Mabinogi Rep: 1,110
    Posts: 43
    Member
    tried on steam, and still the same problem. today a friend and i watched my memory as a opened mabi and it never hit the critical zone >.<?? ( and that was with SKYPE open which seems to use the most memory for me)
  • MiricielMiriciel
    Mabinogi Rep: 815
    Posts: 38
    Member
    That your problem, 32 bits windows.

    you have 4gb ram and procesor, you can format your PC and install win 7 pro (Is easy, with USB BOOT and very fast).
  • ChaikatChaikat
    Mabinogi Rep: 1,110
    Posts: 43
    Member
    hmm for right now i dont wanna go ahead and make any major changes to my pc >.< (atleast not to windows 7 since im planning on maybe just upgrading to 64bit on windows 10 smetime in the future) do you maybe know any other temporary fixes?
    not sure if i said already but this started after a windows update x.x i undid the update but it still isnt working...
    my memory seems rather normal so i dont think its that especially since a friend helped me clean my memory and it made no difference u-u
  • MiricielMiriciel
    Mabinogi Rep: 815
    Posts: 38
    Member
    Well, other options are:

    - Unistall Mabinogi and Nexon Launcher
    - Cleaner
    - Reinstall Mabinogi

    Also, you can open you Event Viewer and find the aplications log, try to find any "red or yellow problem" with Mabinogi. If you find a problem, write it here.

    The problem itself (in my opinion) is that every Mabinogi update, the game worsens its way of managing memory and memory leaks occur. I have experience in it with games like RUST or TERA since I tried to play them on PC with very low ram (Tera Online in 2GB Ram haha). However more than a problem with the minimum requirement that Mabinogi (which obviously complies), is something with the 32 bits.

    If it did not happen before, you can make a backup at the time that the problem did not happen to you.

    Greetings.

  • ChaikatChaikat
    Mabinogi Rep: 1,110
    Posts: 43
    Member
    edited July 17, 2017
    <.> tried all that, still no luck. thought for sure doing a system restore would fix it but it didnt x-x thanks for all the help lol, i think imma just have to quit mabi since ive spent so many hours trying to fix it and nothing made a difference v.v i can run any other game w/o problems but mabi just will not work :(
    thanks again
  • kjnkdjwnkkjnkdjwnk
    Mabinogi Rep: 210
    Post: 1
    Member
    w10 64bit
    i7k process
    16g Nvidia GTX GPU
    16G RAM
    ZX270 Gaming motherboard
    I still have this problem
    confirmed Nexon issue.
    Tenrain
  • TenrainTenrain
    Mabinogi Rep: 800
    Posts: 12
    Member
    I'm running on an i7 16gb ram w10 too, and the memory crashes are only escalating recently, never use to have these problems.