[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Big Performance Issue(Help Is very Required)

GoldenBoy108GoldenBoy108
Mabinogi Rep: 510
Posts: 7
Member
edited January 7, 2017 in Technical Support
So, I just got enough courage to download the game again, I got this new computer and it could run alot of triple A games very well, What i seem to be having an issue with though, is my favorite game, Mabinogi :D
-I noticed when i logged in, everything is more smoother, but the gameplay is not fluent. Whenever i used a skill, such as smash, or defense, the skill gets delayed an extra 3 seconds, and when i try to use a basic attack, the character is just standing there, nothing doing anything for a bit.
-I tried summoning and teleporting, and the delay still occurs, i have also tried turning off quest displays. Nothing
The only concern i have is, why is this game giving me issues?
My specs if anyone is concerned, i would also give out my skype and discord if anyone can assist me with this issue
- Intel(R) Core(TM) i3-4150 CPU @ 3.50GHz
-Microsoft Windows 8.1 (build 9600), 64-bit
-NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
-GTX 745 (GeForce Series)
One last Thing, I have A recording of the issue at hand, Please talk to me, so you can see the thing that im talking about <3

Comments

  • KororeKorore
    Mabinogi Rep: 3,745
    Posts: 667
    Member
    edited January 7, 2017
    It sounds like you may have Nagle's algorithm enabled.

    There is a guide on how to disable Nagle's algorithm, and it solves 99% of the issues regarding slow skill loading (assuming your internet is not acting up) on the Mabinogi Wiki. I personally don't have it disabled and Mabinogi runs fine for me, but I know lots of people disable it solely for Mabinogi.

    Link: http://wiki.mabinogiworld.com/view/Lag#Disabling_Nagle.27s_Algorithm

    WARNING: Only do this if you are confident you know what you are doing and following instructions 100%, as you are going into registry files, and messing something up in there can be critical to your PC.
  • GoldenBoy108GoldenBoy108
    Mabinogi Rep: 510
    Posts: 7
    Member
    I have tried disabling Nagles Algorithm with a GM like 3 months ago, But that is the only step i took from him.
    -It did not work :(
  • GaeaGaea
    Mabinogi Rep: 37,660
    Posts: 5,876
    Member
    Are your graphics drivers all up to date? I would try that, I recommend checking what driver's are available at Nvidia's website because sometimes windows won't retrieve the most up to date driver.

    Besides that from what I have researched windows 8.1 has compatibility and performance issues with certain games. With Mabinogi using extremely outdated engines you may continue encounter issues. Honestly I would recommend downgrading to windows 7 lol. If that's not possible I advise taking some time to review what kind of processes and features are running in the background that you don't need.
  • GoldenBoy108GoldenBoy108
    Mabinogi Rep: 510
    Posts: 7
    Member
    Alright i guess i can try it out, kinda wish i had more insight on my issue, as the only thing i run when i play games is skype xD
  • HardmuscleHardmuscle
    Mabinogi Rep: 12,675
    Posts: 2,548
    Member
    edited January 8, 2017
    Are you using a 'wireless' or 'wired' mouse and keyboard?

    If you have a wireless set, that could be your culprit. ☺

    As for your operating system, I don't think that's an issue.

    I'm on 64-bit Windows 10 with Nvidia Geforce GT 720.

    (I was on 8.1 before 10 [with the same card] and had no problems).

    I used to have similar delays using a wireless mouse and keyboard (poor signal strength).

    I went out and bought a wired set and haven't had a delay since.

    I miss my wireless, but I'd rather have something that works when I use it. ☺

    ---

    As for turning off system background processes; the first thing I murder on any system (aside from the anti-virus performance hog) is the Indexing Service (Windows Search Indexer), for a notable performance increase of about 200-300%. ~ http://i.imgur.com/is2G1jI.png
    Gaea
  • TsumukuTsumuku
    Mabinogi Rep: 990
    Posts: 91
    Member
    you could try using Netalyzr, It is a program that Berkeley hosts and gives some great insight into possible network configuration issues.
    Other than that, knowing what server you're playing on would be greatly helpful. If you're trying to play on Ch1 Alexina for example, I can tell you that the servers are at fault for your lag. Changing Channel would help greatly. The lag on Ch1 has been confirmed by playing with multiple people from several locations meaning several paths and IPs.

    I would be hesitant to say that it is anything wrong with your laptop, especially if you're able to play other games well enough. Given your setup, Mabinogi probably isn't going to make use of your Geforce though. Still the same ongoing lack of care for Optimus users, that being said, integrated graphics on Intel is more than enough for playing Mabinogi.
    Hardmuscle
  • GaeaGaea
    Mabinogi Rep: 37,660
    Posts: 5,876
    Member
    edited January 9, 2017
    Yeah that indexing thing, whoooo boy. One of the culprits that was causing 100% disk usage in windows 10.

    So here is how you do it for windows 8.1 permanently...

    Press Windows Key + R, type services.msc and hit enter, find Windows Search in that list - right click and select properties, from the drop down menu that says "Startup type" select Disabled, click apply. Done.

    I suggest doing this for Superfetch too while you're in there.
    Hardmuscle
  • GoldenBoy108GoldenBoy108
    Mabinogi Rep: 510
    Posts: 7
    Member
    Thanks guys, you helped alot :D
    Hardmuscle
  • GaeaGaea
    Mabinogi Rep: 37,660
    Posts: 5,876
    Member
    edited January 9, 2017
    Good deal. Are you having better performance now?

    If not I have a few more tricks up my sleeve for you. :)
  • ShadowsFox3ShadowsFox3
    Mabinogi Rep: 300
    Posts: 6
    Member
    I think i'm having a similar issue with the game. I seem to lag everywhere when i'm not in a dungeon or shadowmission. I'll just walk for a bit before it jumps every few seconds and it's very irritating since I just got my drivers updated and cleaned out a lot of stuff in the computer.

    Processor: Intel Xeon W3550 3.07 GHz (8cpus), ~3.1GHz
    Windows