Check out all of the details of this month's Patch Notes, featuring the Dungeon RE:Fine Update and the Beauty Update!
https://mabinogi.nexon.net/news/69447/patch-notes-october-7th-2021
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Is text lag complete gone now?

ErikaErika
Mabinogi Rep: 3,220
Posts: 256
Member
in General Chat
In an update earlier this year, they made some changes to fix a lot of the framerate drops caused by having too much text rendered on the screen. Some examples of this included:

1. Having quest markers enabled and having a lot of incomplete quests would cause the game client to "skip" a couple of frames every few seconds.
2. Opening the message log window would cause the game client to freeze for a few seconds while it opened up.
3. Other windows with a lot of text (the Keyword tab in the Character window, the achievement Journal window, etc.) would also cause the client to freeze for a few seconds.

After that update, all of the above stopped happening. However, there was still one instance I knew that still caused the framerate to drop heavily: opening the Pet window (if you have a lot of pets). After last week's update, this doesn't seem to happen anymore! Even on my full list of pets, there is no noticeable drop in framerate (I could be wrong, but it seems like it's a consistent 60 fps for me).

So, I really appreciate these performance/QoL fixes made to Mabi. Now, if they could just fix it so the game could handle like, more than 10 players on screen at once (like at event gatherings or raids) and make places like Tara load faster... then we'd be pretty much golden. I think.
BronzebreakLaticija

Comments

  • BronzebreakBronzebreak
    Mabinogi Rep: 3,730
    Posts: 489
    Member
    edited October 16, 2018
    Erika wrote: »
    So, I really appreciate these performance/QoL fixes made to Mabi. Now, if they could just fix it so the game could handle like, more than 10 players on screen at once (like at event gatherings or raids) and make places like Tara load faster... then we'd be pretty much golden. I think.

    Perhaps a hardware/internet problem (though much more likely the former); my school residence's 16Mbps and year-old-gaming computer handles those and more just fine.

    That being said, the update happened after I moved 1200kms and a mountain range closer to the servers, so I can't compare 'distance from server', though I'm sure it's relevant as well.
  • ErikaErika
    Mabinogi Rep: 3,220
    Posts: 256
    Member
    Perhaps a hardware/internet problem (though much more likely the former); my school residence's 16Mbps and year-old-gaming computer handles those and more just fine.

    That being said, the update happened after I moved 1200kms and a mountain range closer to the servers, so I can't compare 'distance from server', though I'm sure it's relevant as well.

    I have an 80Mbps connection currently. My current PC has an Intel i7 CPU, GeForce 880 GPU, 32GB RAM, and the primary drive is an SSD. It's definitely not a hardware/connection issue. :P Honestly, even PCs older/weaker than mine are more than enough to handle Mabi.

    To be clear: I don't have any performance issues once in places like Tara; just that the initial loading takes notably longer than anywhere else. This has more to due with rendering issues with the game engine itself. Seeing how they've been able to make other performance gains with the game throughout the year... maybe it's even possible for them to fix things like this.
  • BronzebreakBronzebreak
    Mabinogi Rep: 3,730
    Posts: 489
    Member
    Erika wrote: »

    To be clear: I don't have any performance issues once in places like Tara; just that the initial loading takes notably longer than anywhere else.

    Ah, FE.

    I just spam warped some and got an average load time of 4s for other locations, and 8s for Tara (with quick load entry, at High for both) so I see what you mean.
  • ZarricZarric
    Mabinogi Rep: 2,210
    Posts: 80
    Member
    The Character Selection screen and Pet Window doesn't lag anymore, but the 290 update introduced other issues that are noticed. Changing channels now has a graphical lag, which varies for people, but for me lasts for 4~5 seconds on average. I can go from having 100+ fps in an area, change channels still being in the same area and drop to under half that at least. After it stops it's back to the normal fps it should be at.

    If you also open the options in the system menu, you will notice the lag issue too. And finally there's a slight pet lag when de-summoning pets, which is a slightly inconvenient issue I don't like.
    My computer isn't a potato, but it's not top of the line either. I'm on a wired connection with 115/11 down/up and I was able to play without any issues before the last maintenance and 290 just did something that needs to be fixed. Like if I had to describe what happened was the character selection and pet window had lag, and w/e was messed with switched that with normal operations of the client.
    And I also noticed my cached characters had their robe hoods up after the last maintenance as well, when I know for a fact they were down prior to it.
  • JazmynJazmyn
    Mabinogi Rep: 7,595
    Posts: 1,009
    Member
    Zarric wrote: »
    The Character Selection screen and Pet Window doesn't lag anymore, but the 290 update introduced other issues that are noticed. Changing channels now has a graphical lag, which varies for people, but for me lasts for 4~5 seconds on average. I can go from having 100+ fps in an area, change channels still being in the same area and drop to under half that at least. After it stops it's back to the normal fps it should be at.

    If you also open the options in the system menu, you will notice the lag issue too. And finally there's a slight pet lag when de-summoning pets, which is a slightly inconvenient issue I don't like.
    My computer isn't a potato, but it's not top of the line either. I'm on a wired connection with 115/11 down/up and I was able to play without any issues before the last maintenance and 290 just did something that needs to be fixed. Like if I had to describe what happened was the character selection and pet window had lag, and w/e was messed with switched that with normal operations of the client.
    And I also noticed my cached characters had their robe hoods up after the last maintenance as well, when I know for a fact they were down prior to it.
    I had this too, but I didn't know if it meant anything.
  • AlexisEUAlexisEU
    Mabinogi Rep: 1,400
    Posts: 49
    Member
    edited October 18, 2018
    Zarric wrote: »
    The Character Selection screen and Pet Window doesn't lag anymore, but the 290 update introduced other issues that are noticed. Changing channels now has a graphical lag, which varies for people, but for me lasts for 4~5 seconds on average. I can go from having 100+ fps in an area, change channels still being in the same area and drop to under half that at least. After it stops it's back to the normal fps it should be at.
    Login/Channel Change lag. Does what i suspect is pre-rendering all pet icons, prior to this update pet icons were live model renders.
    If that is the case, i personally do not like this change.