Check out all of the details of this month's Patch Notes, featuring the Renovation Season 3 Update!
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Login Error And Blank White Screen

Mabinogi Rep: 105
Posts: 5
in Technical Support
So for a few days now I been having this problem of getting stuck at login screen. Been playing for months now and this problems never appear.
So it consist of like, 3 kind of error ranging from :

-Server cannot be reached.
-An error has occured during authorization. Unable to connect to SSO authorization server.
-And the third one doesn't give me an error message.When I opened the game(through the Nexon launcher like usual), instead of the usual two button of Start Mabinogi and Exit button, It actually gave me a login box that need me to fill my username and password. Ya know, like the old days before Nexon Launcher existed.

So yeah. Me being a dumb stubborn guy, just tried many time to login. When I finally managed to actually get into the game, one more thing I noticed is when i tried to change channel, I will be stuck in a endless white blank screen with no option other than closing the game. Thus, repeated the process of many try to login into the game again.

I would love to know what could be causing all this problem. Nothing really changed on my side. Never installed anything new or made any changes. It always been the same since months ago. Really love to stay with the game again after a few years of hiatus so I really need help here.

Thank you and sorry for my bad english :D



  • KensamaofmariKensamaofmari
    Mabinogi Rep: 34,685
    Posts: 7,898
    Check to make sure your internet is connected. I get SSO a lot when internet crashes and the IP is disrupted.
    Check to make sure you have a valid IP.
    Check to make sure the app has access to firewall.
    Check to make sure that your antivirus isn't preventing the app from accessing the internet.