Check out all of the details of this month's Patch Notes, featuring the Chapter 8: Generation 26 "Winds of Fate" Part 1 Update! https://mabinogi.nexon.net/news/92712/g26-winds-of-fate-part-1-patch-notes-july-11th-2024
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Broom doesn't Sweep when asked (new Event)

FelitraFelitra
Mabinogi Rep: 200
Post: 1
Member
in Help
Hi,
When I first logged into the event, got my broom, etc.. everything seemed fine. It swept up for me twice with no issues. Now, it won't sweep up anything else. I have tried in different towns/locations, tried logging in and out, tried on different days, but still nothing. Is this intermittent sweeping part of the event, or is my broom broken :( (or, am i doing something wrong lol).
Please help :)

Comments

  • ElebonElebon
    Mabinogi Rep: 970
    Posts: 61
    Member, Administrator, Nexon
    Hi @Felitra

    Make sure that you're using the event broom that is given to you by the Street Sweeper. Regular Broom Pets won't sweep up the event item you need, unfortunately. Sweeping also has a cooldown (about 1 minute), so be sure to let your pet take a break after sweeping! You should be sweeping up an item called "Junk in the Trunk" which is a 1x1 consumable item. If you're still having issues, can you provide a video?