Check out all of the details of this month's Patch Notes, featuring the May Quality of Life Updates!
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Google issue ???

Mabinogi Rep: 1,915
Posts: 160
edited February 10, 2019 in Technical Support
that was weird....although i log in using my full email (i never link accounts with social media) i suddenly have been having problems logging in today....i was on earlier, but when i exited the launcher fully then tried to re-log later it kept saying my password was incorrect......i know my password was entered correctly after repeated attempts verified all with the same result.....keyboard did not have CapLock on, nor were any keys stuck.....this happened on two tried my daughter's account....same issue....tried my ex-wife's....same issue.....then i tried to log into the forums to inquire about it....even then it refused because of a password issue....i DID however gain access to the game via Steam, and all is working fine

How then are you able to access the forums then if you can't log in on your browser?

easy....i used Firefox instead of problems logging into either Mabi's Landing Page, nor the Forums the launcher somehow linked via Google, and if so can that that link be terminated.....maybe switched to a different browser entirely....either way the Launcher itself is borked for me right now so i'm using Steam until it's fixed....just letting everyone know my little adventure, and that i was still able to access the game via Steam, and this site via Firefox whereas Chrome kept popping up with the 'Incorrect Password' error

had a thought....since Chrome actually uses Internet Explorer (Edge) as it's base then maybe that could be the issue ....Firefox is a fully independent browser which might be why it didn't have any difficulty


  • aeternitisaeternitis
    Mabinogi Rep: 2,045
    Posts: 142
    May not be related but I could not log onto the website using Chrome until I discovered I had "Block third-party cookies" enabled in Chrome, despite not having touched it. Disabling this allowed me to log in.

    Something to look at anyway.