Check out the patch notes for the Dungeon Guide System update: https://mabinogi.nexon.net/news/63107/dungeon-guide-system-patch-notes-november-12th-2020
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Unable to take the Sword of Elsinore anymore

CapnReconCapnRecon
Mabinogi Rep: 1,055
Posts: 30
Member
edited June 20, 2019 in Bugs and Glitches
https://youtu.be/uiNgX_5Kpa8

The sword is unable to be taken whilst wearing the Rosemary Gloves. I've completed G13 and it's associated sidequests, and the sword doesn't react with the gloves. I've tried emptying out my special inventory and taking bags out of my main inventory. I don't have anything in style tab either. The sword can still be touched without the gloves, and if you have something in your hands with the gloves equipped it tells you to empty your hands. The only thing I've done to my Rosemary Gloves is bless them, and I've also tried emptying my AUX weapon slots. All of it results in the sword doing nothing. Changing channels, relogging, closing and reopening the game hasn't fixed the problem either.

Latest maintenance seems to have fixed the issue.

Server: Alexina
Character: Capnrecon