Check out the patch notes for the September 10th update, Campfire Spirit: https://forums.mabinogi.nexon.net/discussion/23685
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Microsoft Visual C++ dll stated as missing

DrakkletanonDrakkletanon
Mabinogi Rep: 300
Posts: 3
Member
edited June 22, 2019 in Bugs and Glitches
I'm logging in through steam, and since the newest patch as of June 20th my installation has been broken. Yes, I've uninstalled it through steam and reinstalled it. Then I followed up by manually uninstalling all Mabinogi files and re-downloading a second time.rKWMSyK.jpg qe1Zhrd.jpg
EDIT: I've located my .dll files, but the launcher still says they're missing! I can't figure out the issue!

Comments

  • DrakkletanonDrakkletanon
    Mabinogi Rep: 300
    Posts: 3
    Member
    edited June 22, 2019
    This has nothing to do with Steam launcher, I've determined this after some digging and have taken steps to fix the issue with C++. None of which have worked, and i fact I had taken further steps to manually check to see if the .dll files are missing. They are not, and this has become all the more infuriating for that fact.
  • armayarmay
    Mabinogi Rep: 200
    Post: 1
    Member
    Im having the same issue.. :(
  • OdinMOdinM
    Mabinogi Rep: 610
    Posts: 15
    Member
    This is caused by missing Windows Updates.

    You need to install KB2999226, Update for Universal C Runtime in Windows

    This may require additional Windows Updates to be installed for Windows 7 and Windows 8.

    I had a laptop with this error recently and was able to solve it by installing the missing updates.
  • DrakkletannonDrakkletannon
    Mabinogi Rep: 100
    Post: 1
    Member
    I ended up having to do a full reformat. Then Installed C++ 2010 (So that the next step can locate and replace the missing .dll) and THEN the C++ 2015.
    Try doing this BEFORE reformatting though, it might work.
  • NelsaNelsa
    Post: 1
    Member
    Hey, I may have found a solution.

    I was having the same issue on my laptop and I tried downloading the missing dll files is was popping up in the error message but "MSVCP140.dll" kept causing issues, I tried verifying files for Mabi, reinstalling Mabi, neither worked. I ended up uninstalling Visual C++ and then reinstalling it, and that seemed to do the trick.

    To do so:
    Open you Control Panel
    Click on Uninstall a Program
    Find Microsoft Visual C++ (I had multiple versions so I selected to two newest ones, they had a different icon for me than the others) and uninstalled them
    whsj9WB.jpg
    Then I went into my System 32 folder to make sure MSVCP140.dll was gone, which it was.
    Then I went here https://www.microsoft.com/en-us/download/details.aspx?id=48145 to download Microsoft Visual C++ , there are two versions, I download and installed both
    After that I tried to start up Mabi and it worked, so hopefully this will work for others with this issue^^