Check out the patch notes for the September 10th update, Campfire Spirit: https://forums.mabinogi.nexon.net/discussion/23685
[NEW MILLETIANS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.
If this is your first visit, be sure to check out the Nexon Forums Code of Conduct. You have to register before you can post, so you can log in or create a forum name above to proceed. Thank you for your visit!

Missing G23 Book

KalulahKalulah
Mabinogi Rep: 705
Posts: 9
Member
in Bugs and Glitches
I was doing G23's questline, got to the quest titled Page of Darkness. Quest wanted me to examine and then re-examine the black book two more times. On the last objective, the black book completely disappeared from my inventory. It's not in any of my bags, it's not in my Me tab (there's literally no room for it there anyways), I don't have the VIP tab, but I checked it anyways--nothing. It's just gone, and I can't complete the quest because of it.

I'm not sure if it's relevant, but I was on channel 4 (Nao server). I tried to change channels to see if that'd change anything (to channel 6 and then back to 4). The moment I tried to go back to 4, it booted me out of the game saying the "Server cannot be reached." Trying to log back into channel 4 only repeated that issue, but other channels seem to fine. Only mentioning this here since I'm not sure if this is related to why my quest item is missing.

In-game name is Kalulah, if that's needed.